What’s Vulnerable › Vulnerabilities
CVE-2022-50040: net: dsa: sja1105: fix buffer overflow in sja1105_setup_devlink_regions()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-18 · updated 2026-06-17
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: net: dsa: sja1105: fix buffer overflow in sja1105_setup_devlink_regions() If an error occurs in dsa_devlink_region_create(), then 'priv->regions' array will be accessed by negative index '-1'. Found by Linux Verification Center (linuxtesting.org) with SVACE.
Affected products
- Linux kernel: from 5.10 before 5.10.138; from 5.11 before 5.15.63; from 5.16 before 5.19.4; 6.0-rc1 — fixed in 5.10.138, 5.15.63, 5.19.4
How to fix
Upgrade to a fixed version: Linux kernel 5.10.138, 5.15.63, 5.19.4. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/7983e1e44cb322eba6af84160b6d18df80603fb8
- https://git.kernel.org/stable/c/79f86b862416126a2e826cb74224180d6625a32f
- https://git.kernel.org/stable/c/e84c6321f3578c38cb3c24258db91a92672b17a8
- https://git.kernel.org/stable/c/fd8e899cdb5ecaf8e8ee73854a99e10807eef1de
Get alerted when CVE-2022-50040 or the next vulnerability affects your stack