What’s Vulnerable › Vulnerabilities
CVE-2022-50086: block: don't allow the same type rq_qos add more than once
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-18 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: block: don't allow the same type rq_qos add more than once In our test of iocost, we encountered some list add/del corruptions of inner_walk list in ioc_timer_fn. The reason can be described as follows: cpu 0 cpu 1 ioc_qos_write ioc_qos_write ioc = q_to_ioc(queue); if (!ioc) { ioc = kzalloc(); ioc = q_to_ioc(queue); if (!ioc) { ioc = kzalloc(); ... rq_qos_add(q, rqos); } ... rq_qos_add(q, rqos); ... } When the io.cost.qos file is written by two cpus concurrently, rq_qos may be added to one disk twice. In that case, there will be two iocs enabled and running on one disk. They own different iocgs on their active list. In the ioc_timer_fn function, because of the iocgs from two iocs have the same root iocg, the root iocg's walk_list may be overwritten by each other and this leads to list add/del corruptions in building or destroying the inner_walk list. And so far, the blk-rq-qos framework works in case that one instance for one type rq_qos per queue by default. This patch make this explicit and also fix the crash above.
Affected products
- Linux kernel: before 5.15.61; from 5.16 before 5.18.18; from 5.19 before 5.19.2 — fixed in 5.15.61, 5.18.18, 5.19.2
How to fix
Upgrade to a fixed version: Linux kernel 5.15.61, 5.18.18, 5.19.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/08ef66e800a85afc6b54cb95841f6502627eee2e
- https://git.kernel.org/stable/c/0b7f5d7a4d2a72ad9de04ab8ccba2a31904aa638
- https://git.kernel.org/stable/c/0c9bb1acd1d103a3070b2126870eb52761d606ce
- https://git.kernel.org/stable/c/14a6e2eb7df5c7897c15b109cba29ab0c4a791b6
Get alerted when CVE-2022-50086 or the next vulnerability affects your stack