What’s Vulnerable › Vulnerabilities
CVE-2022-50119: rpmsg: Fix possible refcount leak in rpmsg_register_device_override()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-18 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: rpmsg: Fix possible refcount leak in rpmsg_register_device_override() rpmsg_register_device_override need to call put_device to free vch when driver_set_override fails. Fix this by adding a put_device() to the error path.
Affected products
- Linux kernel: from 5.19 before 5.19.2 — fixed in 5.19.2
How to fix
Upgrade to a fixed version: Linux kernel 5.19.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/01e6885b75e25a2dd0726455ef18ef9ce5e7dc87
- https://git.kernel.org/stable/c/280ae5a028ef5d14ef9277746a3026a30aaebe4f
- https://git.kernel.org/stable/c/3fdd5b2bb09fc2b5bf3504778f51c89bb48c097f
- https://git.kernel.org/stable/c/c29335612ff44df979678a38e1f55c62004f421c
- https://git.kernel.org/stable/c/c449b28e437d18ae807479c4ac6b69d87b287c79
- https://git.kernel.org/stable/c/d4c8bf5635c4bedaf2470761ced1f502b2d5434e
- https://git.kernel.org/stable/c/d7bd416d35121c95fe47330e09a5c04adbc5f928
Get alerted when CVE-2022-50119 or the next vulnerability affects your stack