What’s Vulnerable › Vulnerabilities
CVE-2022-50143: intel_th: Fix a resource leak in an error handling path
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-18 · updated 2026-06-17
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: intel_th: Fix a resource leak in an error handling path If an error occurs after calling 'pci_alloc_irq_vectors()', 'pci_free_irq_vectors()' must be called as already done in the remove function.
Affected products
- Linux kernel: from 5.2 before 5.4.211; from 5.5 before 5.10.137; from 5.11 before 5.15.61; from 5.16 before 5.18.18; from 5.19 before 5.19.2 — fixed in 5.10.137, 5.15.61, 5.18.18, 5.19.2, 5.4.211
How to fix
Upgrade to a fixed version: Linux kernel 5.10.137, 5.15.61, 5.18.18, 5.19.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/086c28ab7c5699256aced0049aae9c42f1410313
- https://git.kernel.org/stable/c/859342220accd0d332864fafbf4e3d2d0492bc3f
- https://git.kernel.org/stable/c/9b5469573a274729bdb04b60a8d71f8d09940a31
- https://git.kernel.org/stable/c/a8f3b78b1f8e959d06801ae82149f140a75724e8
- https://git.kernel.org/stable/c/ed4d5ecb7d7fd80336afb2f9ac6685651a6aa32f
- https://git.kernel.org/stable/c/fae9da7d4c2ccad3792de03e3cac1fe2bfabb73d
Get alerted when CVE-2022-50143 or the next vulnerability affects your stack