What’s Vulnerable › Vulnerabilities
CVE-2022-50147: mm/mempolicy: fix get_nodes out of bound access
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-18 · updated 2026-06-17
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: mm/mempolicy: fix get_nodes out of bound access When user specified more nodes than supported, get_nodes will access nmask array out of bounds.
Affected products
- Linux kernel: from 5.15 before 5.15.61; from 5.16 before 5.18.18; from 5.19 before 5.19.2 — fixed in 5.15.61, 5.18.18, 5.19.2
How to fix
Upgrade to a fixed version: Linux kernel 5.15.61, 5.18.18, 5.19.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/000eca5d044d1ee23b4ca311793cf3fc528da6c6
- https://git.kernel.org/stable/c/44652154484e7e3d12008802cfb6c28a8aa16d85
- https://git.kernel.org/stable/c/8176f6a0d9c1b06bc7af7c3d6acd4a66448939df
- https://git.kernel.org/stable/c/d1b5113674c3e95bb53c601ce2ea4719e851c74d
Get alerted when CVE-2022-50147 or the next vulnerability affects your stack