What’s Vulnerable › Vulnerabilities
CVE-2022-50169: wifi: wil6210: debugfs: fix info leak in wil_write_file_wmi()
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-18 · updated 2026-06-17
- Weakness: CWE-909
Description
In the Linux kernel, the following vulnerability has been resolved: wifi: wil6210: debugfs: fix info leak in wil_write_file_wmi() The simple_write_to_buffer() function will succeed if even a single byte is initialized. However, we need to initialize the whole buffer to prevent information leaks. Just use memdup_user().
Affected products
- Linux kernel: from 3.17 before 4.14.291; from 4.15 before 4.19.256; from 4.20 before 5.4.211; from 5.5 before 5.10.137; from 5.11 before 5.15.61; from 5.16 before 5.18.18 — fixed in 4.14.291, 4.19.256, 5.10.137, 5.15.61, 5.18.18, 5.19.2
How to fix
Upgrade to a fixed version: Linux kernel 4.14.291, 4.19.256, 5.10.137, 5.15.61. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/05ceda14ef7c73104e709c414c3680d8a59f51d4
- https://git.kernel.org/stable/c/074e865b37da55aa87baa16d68b96896f85f8adb
- https://git.kernel.org/stable/c/4615458db7793fadc6d546ac3564b36819e77a22
- https://git.kernel.org/stable/c/60c9983425167ec5073c628d83a6875760d18059
- https://git.kernel.org/stable/c/67470920cd3f3cb38699b1ad23234f96bead4d21
- https://git.kernel.org/stable/c/789edc1af9c1a2293956e8534bfef3d18d629de9
- https://git.kernel.org/stable/c/7a4836560a6198d245d5732e26f94898b12eb760
- https://git.kernel.org/stable/c/c1216e699a1ce83ea005510844bd7508d34c6cef
Get alerted when CVE-2022-50169 or the next vulnerability affects your stack