What’s Vulnerable › Vulnerabilities
CVE-2022-50201: selinux: fix memleak in security_read_state_kernel()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-18 · updated 2026-06-17
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: selinux: fix memleak in security_read_state_kernel() In this function, it directly returns the result of __security_read_policy without freeing the allocated memory in *data, cause memory leak issue, so free the memory if __security_read_policy failed. [PM: subject line tweak]
Affected products
- Linux kernel: from 5.12 before 5.15.61; from 5.16 before 5.18.18; from 5.19 before 5.19.2 — fixed in 5.15.61, 5.18.18, 5.19.2
How to fix
Upgrade to a fixed version: Linux kernel 5.15.61, 5.18.18, 5.19.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1fc1f72aad2070d34022d0823e4cf09706b53f25
- https://git.kernel.org/stable/c/73de1befcc53a7c68b0c5e76b9b5ac41c517760f
- https://git.kernel.org/stable/c/c877c5217145bda8fd95f506bf42f8d981afa57d
- https://git.kernel.org/stable/c/f3cd7562c0a6774fc62d79654482014020e574f5
Get alerted when CVE-2022-50201 or the next vulnerability affects your stack