What’s Vulnerable › Vulnerabilities
CVE-2022-50218: iio: light: isl29028: Fix the warning in isl29028_remove()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-18 · updated 2026-06-17
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: iio: light: isl29028: Fix the warning in isl29028_remove() The driver use the non-managed form of the register function in isl29028_remove(). To keep the release order as mirroring the ordering in probe, the driver should use non-managed form in probe, too. The following log reveals it: [ 32.374955] isl29028 0-0010: remove [ 32.376861] general protection fault, probably for non-canonical address 0xdffffc0000000006: 0000 [#1] PREEMPT SMP KASAN PTI [ 32.377676] KASAN: null-ptr-deref in range [0x0000000000000030-0x0000000000000037] [ 32.379432] RIP: 0010:kernfs_find_and_get_ns+0x28/0xe0 [ 32.385461] Call Trace: [ 32.385807] sysfs_unmerge_group+0x59/0x110 [ 32.386110] dpm_sysfs_remove+0x58/0xc0 [ 32.386391] device_del+0x296/0xe50 [ 32.386959] cdev_device_del+0x1d/0xd0 [ 32.387231] devm_iio_device_unreg+0x27/0xb0 [ 32.387542] devres_release_group+0x319/0x3d0 [ 32.388162] i2c_device_remove+0x93/0x1f0
Affected products
- Linux kernel: from 4.11 before 4.14.291; from 4.15 before 4.19.256; from 4.20 before 5.4.211; from 5.5 before 5.10.137; from 5.11 before 5.15.61; from 5.16 before 5.18.18 — fixed in 4.14.291, 4.19.256, 5.10.137, 5.15.61, 5.18.18, 5.19.2
How to fix
Upgrade to a fixed version: Linux kernel 4.14.291, 4.19.256, 5.10.137, 5.15.61. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/06674fc7c003b9d0aa1d37fef7ab2c24802cc6ad
- https://git.kernel.org/stable/c/359f3b150eab30805fe0e4e9d616887d7257a625
- https://git.kernel.org/stable/c/4f0ebfb4b9bfad2326c0b2c3cc7e37f4b9ee9eba
- https://git.kernel.org/stable/c/a1135205b0affd255510775a27df571aca84ab4b
- https://git.kernel.org/stable/c/ca63d5abf404d2934e2ac03545350de7bb8c8e96
- https://git.kernel.org/stable/c/ed43fb20d3d1fca9d79db0d5faf4321a4dd58c23
- https://git.kernel.org/stable/c/fac589fb764699a4bcd288f6656b8cd0408ea968
- https://git.kernel.org/stable/c/fb1888205c0782f287e5dd4ffff1f665332e868c
Get alerted when CVE-2022-50218 or the next vulnerability affects your stack