What’s Vulnerable › Vulnerabilities
CVE-2022-50235: NFSD: Protect against send buffer overflow in NFSv2 READDIR
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-15 · updated 2026-08-04
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: NFSD: Protect against send buffer overflow in NFSv2 READDIR Restore the previous limit on the @count argument to prevent a buffer overflow attack.
Affected products
- Linux kernel: from 5.15.12 before 5.15.75; from 5.16.1 before 5.19.17; from 6.0 before 6.0.3; 5.16, 5.16-rc7, 5.16-rc8 — fixed in 5.15.75, 5.19.17, 6.0.3
How to fix
Upgrade to a fixed version: Linux kernel 5.15.75, 5.19.17, 6.0.3. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/00b4492686e0497fdb924a9d4c8f6f99377e176c
- https://git.kernel.org/stable/c/0e57d696f60dee6117a8ace0cac7c5761d375277
- https://git.kernel.org/stable/c/c2a878095b5c6f04f90553a3c45872f990dab14e
- https://git.kernel.org/stable/c/dc7f225090c29a5f3b9419b1af32846a201555e7
- https://git.kernel.org/stable/c/f59c74df82f6ac9d2ea4e01aa3ae7c6c4481652d
Get alerted when CVE-2022-50235 or the next vulnerability affects your stack