What’s Vulnerable › Vulnerabilities
CVE-2022-50264: clk: socfpga: Fix memory leak in socfpga_gate_init()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-15 · updated 2026-06-17
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: clk: socfpga: Fix memory leak in socfpga_gate_init() Free @socfpga_clk and @ops on the error path to avoid memory leak issue.
Affected products
- Linux kernel: from 5.1 before 5.4.229; from 5.5 before 5.10.163; from 5.11 before 5.15.86; from 5.16 before 6.0.16; from 6.1 before 6.1.2 — fixed in 5.10.163, 5.15.86, 5.4.229, 6.0.16, 6.1.2
How to fix
Upgrade to a fixed version: Linux kernel 5.10.163, 5.15.86, 5.4.229, 6.0.16. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0b8ba891ad4d1ef6bfa4c72efc83f9f9f855f68b
- https://git.kernel.org/stable/c/3e8fd1d0fab4d5c9a50d225dddc207deac12f13a
- https://git.kernel.org/stable/c/6f2198914fb9aac286a6ff6cf09b23752141e04f
- https://git.kernel.org/stable/c/9de42116fc4540f6a1ceb51fd037b734ab7be12e
- https://git.kernel.org/stable/c/9f9bb9f5ba9fd501a90f255eb746b4cf2ceeaaae
- https://git.kernel.org/stable/c/bd72ab5e6fc1c4d3e6b84636141d26a41b977b03
Get alerted when CVE-2022-50264 or the next vulnerability affects your stack