What’s Vulnerable › Vulnerabilities
CVE-2022-50277: ext4: don't allow journal inode to have encrypt flag
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-15 · updated 2026-06-17
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: ext4: don't allow journal inode to have encrypt flag Mounting a filesystem whose journal inode has the encrypt flag causes a NULL dereference in fscrypt_limit_io_blocks() when the 'inlinecrypt' mount option is used. The problem is that when jbd2_journal_init_inode() calls bmap(), it eventually finds its way into ext4_iomap_begin(), which calls fscrypt_limit_io_blocks(). fscrypt_limit_io_blocks() requires that if the inode is encrypted, then its encryption key must already be set up. That's not the case here, since the journal inode is never "opened" like a normal file would be. Hence the crash. A reproducer is: mkfs.ext4 -F /dev/vdb debugfs -w /dev/vdb -R "set_inode_field <8> flags 0x80808" mount /dev/vdb /mnt -o inlinecrypt To fix this, make ext4 consider journal inodes with the encrypt flag to be invalid. (Note, maybe other flags should be rejected on the journal inode too. For now, this is just the minimal fix for the above issue.) I've marked this as fixing the commit that introduced the call to fscrypt_limit_io_blocks(), since that's what made an actual crash start being possible. But this fix could be applied to any version of ext4 that supports the encrypt feature.
Affected products
- Linux kernel: from 5.18 before 6.0.18; from 6.1 before 6.1.4 — fixed in 6.0.18, 6.1.4
How to fix
Upgrade to a fixed version: Linux kernel 6.0.18, 6.1.4. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/105c78e12468413e426625831faa7db4284e1fec
- https://git.kernel.org/stable/c/1f7a6626f611aa06d7907aa45b484708dd5ac8bc
- https://git.kernel.org/stable/c/bcc5057e1781a3ee889225480d995c3b5cbde555
Get alerted when CVE-2022-50277 or the next vulnerability affects your stack