What’s Vulnerable › Vulnerabilities
CVE-2022-50293: btrfs: do not BUG_ON() on ENOMEM when dropping extent items for a range
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-15 · updated 2026-06-17
- Weakness: CWE-617
Description
In the Linux kernel, the following vulnerability has been resolved: btrfs: do not BUG_ON() on ENOMEM when dropping extent items for a range If we get -ENOMEM while dropping file extent items in a given range, at btrfs_drop_extents(), due to failure to allocate memory when attempting to increment the reference count for an extent or drop the reference count, we handle it with a BUG_ON(). This is excessive, instead we can simply abort the transaction and return the error to the caller. In fact most callers of btrfs_drop_extents(), directly or indirectly, already abort the transaction if btrfs_drop_extents() returns any error. Also, we already have error paths at btrfs_drop_extents() that may return -ENOMEM and in those cases we abort the transaction, like for example anything that changes the b+tree may return -ENOMEM due to a failure to allocate a new extent buffer when COWing an existing extent buffer, such as a call to btrfs_duplicate_item() for example. So replace the BUG_ON() calls with proper logic to abort the transaction and return the error.
Affected products
- Linux kernel: before 5.15.86; from 5.16 before 6.0.16; from 6.1 before 6.1.2 — fixed in 5.15.86, 6.0.16, 6.1.2
How to fix
Upgrade to a fixed version: Linux kernel 5.15.86, 6.0.16, 6.1.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/162d053e15fe985f754ef495a96eb3db970c43ed
- https://git.kernel.org/stable/c/1baf3370e2dc5e6bd1368348736189457dab2a27
- https://git.kernel.org/stable/c/50f993da945074b2a069da099a0331b23a0c89a0
- https://git.kernel.org/stable/c/7fbcb635c8fc927d139f3302babcf1b42c09265c
Get alerted when CVE-2022-50293 or the next vulnerability affects your stack