What’s Vulnerable › Vulnerabilities
CVE-2022-50319: coresight: trbe: remove cpuhp instance node before remove cpuhp state
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-15 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: coresight: trbe: remove cpuhp instance node before remove cpuhp state cpuhp_state_add_instance() and cpuhp_state_remove_instance() should be used in pairs. Or there will lead to the warn on cpuhp_remove_multi_state() since the cpuhp_step list is not empty. The following is the error log with 'rmmod coresight-trbe': Error: Removing state 215 which has instances left. Call trace: __cpuhp_remove_state_cpuslocked+0x144/0x160 __cpuhp_remove_state+0xac/0x100 arm_trbe_device_remove+0x2c/0x60 [coresight_trbe] platform_remove+0x34/0x70 device_remove+0x54/0x90 device_release_driver_internal+0x1e4/0x250 driver_detach+0x5c/0xb0 bus_remove_driver+0x64/0xc0 driver_unregister+0x3c/0x70 platform_driver_unregister+0x20/0x30 arm_trbe_exit+0x1c/0x658 [coresight_trbe] __arm64_sys_delete_module+0x1ac/0x24c invoke_syscall+0x50/0x120 el0_svc_common.constprop.0+0x58/0x1a0 do_el0_svc+0x38/0xd0 el0_svc+0x2c/0xc0 el0t_64_sync_handler+0x1ac/0x1b0 el0t_64_sync+0x19c/0x1a0 ---[ end trace 0000000000000000 ]---
Affected products
- Linux kernel: from 5.13 before 5.15.86; from 5.16 before 6.0.16; from 6.1 before 6.1.2 — fixed in 5.15.86, 6.0.16, 6.1.2
How to fix
Upgrade to a fixed version: Linux kernel 5.15.86, 6.0.16, 6.1.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/18b9202188a4e59923834c60b5c82ea1da7d1811
- https://git.kernel.org/stable/c/20ee8c223f792947378196307d8e707c9cdc2d61
- https://git.kernel.org/stable/c/2ea334960afcd49385840c7afd59fc5f8d3ce682
- https://git.kernel.org/stable/c/3c18888bc0b51835c74123b1e04d5df11543724c
Get alerted when CVE-2022-50319 or the next vulnerability affects your stack