What’s Vulnerable › Vulnerabilities
CVE-2022-50348: nfsd: Fix a memory leak in an error handling path
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-16 · updated 2026-06-17
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: nfsd: Fix a memory leak in an error handling path If this memdup_user() call fails, the memory allocated in a previous call a few lines above should be freed. Otherwise it leaks.
Affected products
- Linux kernel: from 5.4 before 5.4.220; from 5.5 before 5.10.150; from 5.11 before 5.15.75; from 5.16 before 5.19.17; from 6.0 before 6.0.3 — fixed in 5.10.150, 5.15.75, 5.19.17, 5.4.220, 6.0.3
How to fix
Upgrade to a fixed version: Linux kernel 5.10.150, 5.15.75, 5.19.17, 5.4.220. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/733dd17158f96aaa25408dc39bbb2738fda9300e
- https://git.kernel.org/stable/c/acc393aecda05bf64ed13b732931462e07a1bf08
- https://git.kernel.org/stable/c/aed8816305575b38dcc77feb6f1bc1d0ed32f5b8
- https://git.kernel.org/stable/c/cc3bca2110ac85cd964da997ef83d84cab0d49fb
- https://git.kernel.org/stable/c/e060c4b9f33c1fca74df26d57a98e784295327e6
- https://git.kernel.org/stable/c/fd1ef88049de09bc70d60b549992524cfc0e66ff
Get alerted when CVE-2022-50348 or the next vulnerability affects your stack