What’s Vulnerable › Vulnerabilities
CVE-2022-50368: drm/msm/dsi: fix memory corruption with too many bridges
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-17 · updated 2026-06-17
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: drm/msm/dsi: fix memory corruption with too many bridges Add the missing sanity check on the bridge counter to avoid corrupting data beyond the fixed-sized bridge array in case there are ever more than eight bridges. Patchwork: https://patchwork.freedesktop.org/patch/502668/
Affected products
- Linux kernel: from 4.1 before 4.19.264; from 4.20 before 5.4.223; from 5.5 before 5.10.153; from 5.11 before 5.15.77; from 5.16 before 6.0.7; 6.1-rc1, 6.1-rc2 — fixed in 4.19.264, 5.10.153, 5.15.77, 5.4.223, 6.0.7
How to fix
Upgrade to a fixed version: Linux kernel 4.19.264, 5.10.153, 5.15.77, 5.4.223. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/21c4679af01f1027cb559330c2e7d410089b2b36
- https://git.kernel.org/stable/c/2e786eb2f9cebb07e317226b60054df510b60c65
- https://git.kernel.org/stable/c/4e5587cddb334f7a5bb1c49ea8bbfc966fafe1b8
- https://git.kernel.org/stable/c/9f035d1fb30648fe70ee01627eb131c56d699b35
- https://git.kernel.org/stable/c/e83b354890a3c1d5256162f87a6cc38c47ae7f20
- https://git.kernel.org/stable/c/f649ed0e1b7a1545f8e27267d3c468b3cb222ece
Get alerted when CVE-2022-50368 or the next vulnerability affects your stack