What’s Vulnerable › Vulnerabilities
CVE-2022-50399: media: atomisp: prevent integer overflow in sh_css_set_black_frame()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-18 · updated 2026-08-04
- Weakness: CWE-190
Description
In the Linux kernel, the following vulnerability has been resolved: media: atomisp: prevent integer overflow in sh_css_set_black_frame() The "height" and "width" values come from the user so the "height * width" multiplication can overflow.
Affected products
- Linux kernel: from 4.12 before 4.18; from 5.8 before 5.15.77; from 5.16 before 6.0.7; 6.1-rc1 — fixed in 4.18, 5.15.77, 6.0.7
How to fix
Upgrade to a fixed version: Linux kernel 4.18, 5.15.77, 6.0.7. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/3ad290194bb06979367622e47357462836c1d3b4
- https://git.kernel.org/stable/c/51b8dc5163d2ff2bf04019f8bf7e3bd0e75bb654
- https://git.kernel.org/stable/c/a549517e4b761f3940011db30320cb8c9badde54
- https://git.kernel.org/stable/c/a560aeac2f2d284903b5900774765d7fc61547bc
Get alerted when CVE-2022-50399 or the next vulnerability affects your stack