What’s Vulnerable › Vulnerabilities
CVE-2022-50421: rpmsg: char: Avoid double destroy of default endpoint
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-01 · updated 2026-06-17
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: rpmsg: char: Avoid double destroy of default endpoint The rpmsg_dev_remove() in rpmsg_core is the place for releasing this default endpoint. So need to avoid destroying the default endpoint in rpmsg_chrdev_eptdev_destroy(), this should be the same as rpmsg_eptdev_release(). Otherwise there will be double destroy issue that ept->refcount report warning: refcount_t: underflow; use-after-free. Call trace: refcount_warn_saturate+0xf8/0x150 virtio_rpmsg_destroy_ept+0xd4/0xec rpmsg_dev_remove+0x60/0x70 The issue can be reproduced by stopping remoteproc before closing the /dev/rpmsgX.
Affected products
- Linux kernel: from 5.18 before 5.19.17; from 6.0 before 6.0.3 — fixed in 5.19.17, 6.0.3
How to fix
Upgrade to a fixed version: Linux kernel 5.19.17, 6.0.3. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/3f20ef7a845c2c8d7ec82ecffa20d95cab5ecfeb
- https://git.kernel.org/stable/c/467233a4ac29b215d492843d067a9f091e6bf0c5
- https://git.kernel.org/stable/c/ef828a39d6a7028836eaf37df3ad568c8c2dd6f9
Get alerted when CVE-2022-50421 or the next vulnerability affects your stack