What’s Vulnerable › Vulnerabilities
CVE-2022-50427: ALSA: ac97: fix possible memory leak in snd_ac97_dev_register()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-01 · updated 2026-06-17
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: ALSA: ac97: fix possible memory leak in snd_ac97_dev_register() If device_register() fails in snd_ac97_dev_register(), it should call put_device() to give up reference, or the name allocated in dev_set_name() is leaked.
Affected products
- Linux kernel: from 2.6.14 before 4.9.332; from 4.10 before 4.14.298; from 4.15 before 4.19.264; from 4.20 before 5.4.223; from 5.5 before 5.10.153; from 5.11 before 5.15.77 — fixed in 4.14.298, 4.19.264, 4.9.332, 5.10.153, 5.15.77, 5.4.223
How to fix
Upgrade to a fixed version: Linux kernel 4.14.298, 4.19.264, 4.9.332, 5.10.153. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0f8e9a15c8ecf95057061d370a2dddaf1cee4aeb
- https://git.kernel.org/stable/c/4881bda5ea05c8c240fc8afeaa928e2bc43f61fa
- https://git.kernel.org/stable/c/4fdf6f978c6b605ca0d67bf0e982b7a8fc0f4aab
- https://git.kernel.org/stable/c/758dbcc6fbf2286eff02743b093c70a18a407d66
- https://git.kernel.org/stable/c/a602ec9d88f177dba78bc97fb1adecc7a71ff279
- https://git.kernel.org/stable/c/bfce73088682ef0770da951f51156c36a89be490
- https://git.kernel.org/stable/c/c68b2e9ef246117f696e360bbdd2f5736b3a7127
- https://git.kernel.org/stable/c/ee8bf0946f62ef00e5db4b613a9f664ac567259a
Get alerted when CVE-2022-50427 or the next vulnerability affects your stack