What’s Vulnerable › Vulnerabilities
CVE-2022-50437: drm/msm/hdmi: fix memory corruption with too many bridges
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-01 · updated 2026-08-04
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: drm/msm/hdmi: fix memory corruption with too many bridges Add the missing sanity check on the bridge counter to avoid corrupting data beyond the fixed-sized bridge array in case there are ever more than eight bridges. Patchwork: https://patchwork.freedesktop.org/patch/502670/
Affected products
- Linux kernel: from 3.12 before 4.9.332; from 4.10 before 4.14.298; from 4.15 before 4.19.264; from 4.20 before 5.4.223; from 5.5 before 5.10.153; from 5.11 before 5.15.77 — fixed in 4.14.298, 4.19.264, 4.9.332, 5.10.153, 5.15.77, 5.4.223
How to fix
Upgrade to a fixed version: Linux kernel 4.14.298, 4.19.264, 4.9.332, 5.10.153. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/08c7375fa27a8ceee028868e03ffb3a0db919d44
- https://git.kernel.org/stable/c/3c43f3ec731c233eb84b66199ee76dbf3ec6ecae
- https://git.kernel.org/stable/c/4c1294da6aed1f16d47a417dcfe6602833c3c95c
- https://git.kernel.org/stable/c/9efb45b45ff6254bfd1f1997a06725cb3fc998a5
- https://git.kernel.org/stable/c/a9c1a6991a9b5aa6d0f2cbc9b8c3bf6c4d094dfa
- https://git.kernel.org/stable/c/b48949ab451eaf1e2c04c272c8a9a96a2b56546f
- https://git.kernel.org/stable/c/e8f916b84e4b028ecad6c6472eaad543cc7df806
- https://git.kernel.org/stable/c/ed7f1ff87a4afea1bc220d2ff00a7ce8e61f0b53
Get alerted when CVE-2022-50437 or the next vulnerability affects your stack