What’s Vulnerable › Vulnerabilities
CVE-2022-50448: mm/uffd: fix warning without PTE_MARKER_UFFD_WP compiled in
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-01 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: mm/uffd: fix warning without PTE_MARKER_UFFD_WP compiled in When PTE_MARKER_UFFD_WP not configured, it's still possible to reach pte marker code and trigger an warning. Add a few CONFIG_PTE_MARKER_UFFD_WP ifdefs to make sure the code won't be reached when not compiled in.
Affected products
- Linux kernel: from 5.19 before 5.19.17; from 6.0 before 6.0.3 — fixed in 5.19.17, 6.0.3
How to fix
Upgrade to a fixed version: Linux kernel 5.19.17, 6.0.3. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/2204a880cb0c51952463a24a4fa01a6514c5a25a
- https://git.kernel.org/stable/c/515778e2d790652a38a24554fdb7f21420d91efc
- https://git.kernel.org/stable/c/b76e4eb02e9edb9a0a51942acdb373ca01346e8c
Get alerted when CVE-2022-50448 or the next vulnerability affects your stack