What’s Vulnerable › Vulnerabilities
CVE-2022-50464: mt76: mt7915: Fix PCI device refcount leak in mt7915_pci_init_hif2()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-01 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: mt76: mt7915: Fix PCI device refcount leak in mt7915_pci_init_hif2() As comment of pci_get_device() says, it returns a pci_device with its refcount increased. We need to call pci_dev_put() to decrease the refcount. Save the return value of pci_get_device() and call pci_dev_put() to decrease the refcount.
Affected products
- Linux kernel: from 5.12 before 6.0.16; from 6.1 before 6.1.2 — fixed in 6.0.16, 6.1.2
How to fix
Upgrade to a fixed version: Linux kernel 6.0.16, 6.1.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/2d4b9c7e81f3a4df27749ebecb426b145e68be2a
- https://git.kernel.org/stable/c/5938196cc188ba4323bc6357f5ac55127d715888
- https://git.kernel.org/stable/c/8abc6579667129afd13ff2ccb0319ba3f46e6995
Get alerted when CVE-2022-50464 or the next vulnerability affects your stack