What’s Vulnerable › Vulnerabilities
CVE-2022-50521: platform/x86: mxm-wmi: fix memleak in mxm_wmi_call_mx[ds|mx]()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-07 · updated 2026-06-17
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: platform/x86: mxm-wmi: fix memleak in mxm_wmi_call_mx[ds|mx]() The ACPI buffer memory (out.pointer) returned by wmi_evaluate_method() is not freed after the call, so it leads to memory leak. The method results in ACPI buffer is not used, so just pass NULL to wmi_evaluate_method() which fixes the memory leak.
Affected products
- Linux kernel: from 3.0 before 4.14.303; from 4.15 before 4.19.270; from 4.20 before 5.4.229; from 5.5 before 5.10.163; from 5.11 before 5.15.86; from 5.16 before 6.0.16 — fixed in 4.14.303, 4.19.270, 5.10.163, 5.15.86, 5.4.229, 6.0.16
How to fix
Upgrade to a fixed version: Linux kernel 4.14.303, 4.19.270, 5.10.163, 5.15.86. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/14bb4bde3b7b2584734b13747b345caeeb41bea3
- https://git.kernel.org/stable/c/17cd8c46cbec4e6ad593fb9159928b8e7608c11a
- https://git.kernel.org/stable/c/379e7794c5e7485193d25d73614fbbd1e1387f6f
- https://git.kernel.org/stable/c/3cf81501356c9e898ad94b2369ffc805f83f7d7b
- https://git.kernel.org/stable/c/50ac517d6f5348b276f1f663799cf85dce521518
- https://git.kernel.org/stable/c/5b0f81b0808235967868e01336c976e840217108
- https://git.kernel.org/stable/c/727cc0147f5066e359aca65cc6cc5e6d64cc15d8
- https://git.kernel.org/stable/c/87426ce3bd57ad414b6e2436434ef8128986a9a5
Get alerted when CVE-2022-50521 or the next vulnerability affects your stack