What’s Vulnerable › Vulnerabilities
CVE-2022-50525: iommu/fsl_pamu: Fix resource leak in fsl_pamu_probe()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-07 · updated 2026-06-17
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: iommu/fsl_pamu: Fix resource leak in fsl_pamu_probe() The fsl_pamu_probe() returns directly when create_csd() failed, leaving irq and memories unreleased. Fix by jumping to error if create_csd() returns error.
Affected products
- Linux kernel: from 3.12 before 4.9.337; from 4.10 before 4.14.303; from 4.15 before 4.19.270; from 4.20 before 5.4.229; from 5.5 before 5.10.163; from 5.11 before 5.15.86 — fixed in 4.14.303, 4.19.270, 4.9.337, 5.10.163, 5.15.86, 5.4.229
How to fix
Upgrade to a fixed version: Linux kernel 4.14.303, 4.19.270, 4.9.337, 5.10.163. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0d240ac0e4c35d3f64fc782c11433138c1bd016e
- https://git.kernel.org/stable/c/17fd440594961c5e2ea0f58591bc1bdba0629c75
- https://git.kernel.org/stable/c/73f5fc5f884ad0c5f7d57f66303af64f9f002526
- https://git.kernel.org/stable/c/9238b687fd62cde14c6e2e8576a40e4246de7ebe
- https://git.kernel.org/stable/c/9fbccdf2fefa3944dd8ba8c6a808b387787f3917
- https://git.kernel.org/stable/c/a305d0e4d0ce3166e31d7dbcb4c98b09cad6d49a
- https://git.kernel.org/stable/c/c93983230562883e0b5f122040efbb3d478c36d4
- https://git.kernel.org/stable/c/de7eb55009796687fc0a1670e0b944fa8ed54e9b
- https://git.kernel.org/stable/c/e42b543d08052c3b223bcfb48f05cbaf0b767f86
Get alerted when CVE-2022-50525 or the next vulnerability affects your stack