What’s Vulnerable › Vulnerabilities
CVE-2022-50540: dmaengine: qcom-adm: fix wrong sizeof config in slave_config
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-07 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: dmaengine: qcom-adm: fix wrong sizeof config in slave_config Fix broken slave_config function that uncorrectly compare the peripheral_size with the size of the config pointer instead of the size of the config struct. This cause the crci value to be ignored and cause a kernel panic on any slave that use adm driver. To fix this, compare to the size of the struct and NOT the size of the pointer.
Affected products
- Linux kernel: from 5.17 before 5.19.17; from 6.0 before 6.0.3 — fixed in 5.19.17, 6.0.3
How to fix
Upgrade to a fixed version: Linux kernel 5.19.17, 6.0.3. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/7490274b41a432824f7df5071ace3df2ab59caa7
- https://git.kernel.org/stable/c/7c8765308371be30f50c1b5b97618b731514b207
- https://git.kernel.org/stable/c/f1dd45a6585a1689e1e8906b3f9e302b9d40c715
Get alerted when CVE-2022-50540 or the next vulnerability affects your stack