What’s Vulnerable › Vulnerabilities
CVE-2022-50587: Nagios XI < 5.8.9 Stored XSS via Command Names in Apply Config Error Text
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-30 · updated 2026-10-18
- Weakness: CWE-79
Description
Nagios XI versions prior to 5.8.9 are vulnerable to cross-site scripting (XSS) via the Apply Configuration error text. Insufficient validation or escaping of user-supplied input may allow an attacker to inject and execute arbitrary script in the context of a victim's browser.
Affected products
- Nagios XI: before 5.8.9 — fixed in 5.8.9
How to fix
Upgrade to a fixed version: Nagios XI 5.8.9. Check the vendor advisory for mitigations.
References
- https://www.nagios.com/changelog/nagios-xi/
- https://www.vulncheck.com/advisories/nagios-xi-stored-xss-via-command-names-in-apply-config-error-text
Get alerted when CVE-2022-50587 or the next vulnerability affects your stack