What’s Vulnerable › Vulnerabilities
CVE-2022-50677: ipmi: fix use after free in _ipmi_destroy_user()
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-09 · updated 2026-10-15
Description
In the Linux kernel, the following vulnerability has been resolved: ipmi: fix use after free in _ipmi_destroy_user() The intf_free() function frees the "intf" pointer so we cannot dereference it again on the next line.
Affected products
- Linux kernel: from 4.19.92 before 4.19.270; from 5.4.7 before 5.4.229; 5.5 — fixed in 4.19.270, 5.4.229, 6.2
How to fix
Upgrade to a fixed version: Linux kernel 4.19.270, 5.4.229, 6.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1fc9b20a7688000fcf4d7fbaa58e415a3cdda961
- https://git.kernel.org/stable/c/35ad87bfe330f7ef6a19f772223c63296d643172
- https://git.kernel.org/stable/c/a92ce570c81dc0feaeb12a429b4bc65686d17967
- https://git.kernel.org/stable/c/bfce073089cb81482521c65061835aaa6d1a6cc0
- https://git.kernel.org/stable/c/d23006f2a56e11a3103de0ca8b843bf7fd7d76fc
- https://git.kernel.org/stable/c/f29d127b372e1b7662397d92341d9f7de198ff99
- https://git.kernel.org/stable/c/f7fde441198a9ecb130c3ccec91ee2131d6998ee
Get alerted when CVE-2022-50677 or the next vulnerability affects your stack