What’s Vulnerable › Vulnerabilities
CVE-2022-50812: security: Restrict CONFIG_ZERO_CALL_USED_REGS to gcc or clang > 15.0.6
- Severity: unknown
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-30 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: security: Restrict CONFIG_ZERO_CALL_USED_REGS to gcc or clang > 15.0.6 A bad bug in clang's implementation of -fzero-call-used-regs can result in NULL pointer dereferences (see the links above the check for more information). Restrict CONFIG_CC_HAS_ZERO_CALL_USED_REGS to either a supported GCC version or a clang newer than 15.0.6, which will catch both a theoretical 15.0.7 and the upcoming 16.0.0, which will both have the bug fixed.
Affected products
- Linux kernel: 5.15 — fixed in 6.2
How to fix
Upgrade to a fixed version: Linux kernel 6.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0b202dfedb5aa2e7d07d849be33fa3a48c026926
- https://git.kernel.org/stable/c/21ca0bfa11bbb9a9207f5d2104f47d3d71b4616e
- https://git.kernel.org/stable/c/8a4236456a3a402f6bb92aa7b75e7a3b4ef7a72c
- https://git.kernel.org/stable/c/d6a9fb87e9d18f3394a9845546bbe868efdccfd2
Get alerted when CVE-2022-50812 or the next vulnerability affects your stack