What’s Vulnerable › Vulnerabilities
CVE-2022-51008: PocketMine-MP before 4.12.3 Denial of Service via Unauthenticated Sessions
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-06 · updated 2026-09-08
- Weakness: CWE-770
Description
PocketMine-MP before 4.12.3 fails to limit unauthenticated sessions, allowing attackers to exhaust player slots by creating sessions without sending LoginPacket. Attackers can flood the server with unauthenticated connections that occupy max-player slots, preventing legitimate players from joining.
Affected products
- pmmp PocketMine-MP: from 4.0.0 before 4.12.3 — fixed in 4.12.3
How to fix
Upgrade to a fixed version: pmmp PocketMine-MP 4.12.3. Check the vendor advisory for mitigations.
References
- https://github.com/pmmp/PocketMine-MP/commit/59be901efe6b7833e69e638e0e1497051ce96fa7
- https://github.com/pmmp/PocketMine-MP/security/advisories/GHSA-474q-9hgp-hcvx
- https://www.vulncheck.com/advisories/pocketmine-mp-before-4.12.3-denial-of-service-via-unauthenticated-sessions
Get alerted when CVE-2022-51008 or the next vulnerability affects your stack