What’s Vulnerable › Vulnerabilities
CVE-2022-51009: PocketMine-MP before 4.7.2 Denial of Service via Skin Geometry
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-06 · updated 2026-10-08
- Weakness: CWE-248
Description
PocketMine-MP before 4.7.2 fails to properly handle exceptions from the adhocore/json-comment library when parsing skin geometry data. Attackers can send login or skin packets with invalid geometry JSON to trigger an unhandled RuntimeException, causing server crash.
Affected products
- pmmp PocketMine-MP: before 4.7.2 — fixed in 4.7.2
How to fix
Upgrade to a fixed version: pmmp PocketMine-MP 4.7.2. Check the vendor advisory for mitigations.
References
- https://github.com/pmmp/PocketMine-MP/commit/c9626c610b8f6810c8c987559c9197b2a291f0bb
- https://github.com/pmmp/PocketMine-MP/security/advisories/GHSA-8cwq-4cmf-px73
- https://www.vulncheck.com/advisories/pocketmine-mp-before-4.7.2-denial-of-service-via-skin-geometry
Get alerted when CVE-2022-51009 or the next vulnerability affects your stack