What’s Vulnerable › Vulnerabilities
CVE-2022-51011: PocketMine-MP before 4.2.10 Denial of Service via Chat Messages
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-07 · updated 2026-10-08
- Weakness: CWE-20
Description
PocketMine-MP before 4.2.10 fails to validate the total length of incoming chat message blobs before splitting them by newline characters, allowing attackers to send large messages containing many newlines. Malicious clients can send megabyte-sized chat packets and bombard the server with thousands of such messages, causing server lockups lasting seconds or minutes.
Affected products
- pmmp PocketMine-MP: before 4.2.10 — fixed in 4.2.10
How to fix
Upgrade to a fixed version: pmmp PocketMine-MP 4.2.10. Check the vendor advisory for mitigations.
References
- https://github.com/pmmp/PocketMine-MP/commit/df33e179e5d3ff13b56a2d7060bf592b0f797258
- https://github.com/pmmp/PocketMine-MP/security/advisories/GHSA-gj94-v4p9-w672
- https://www.vulncheck.com/advisories/pocketmine-mp-before-4.2.10-denial-of-service-via-chat-messages
Get alerted when CVE-2022-51011 or the next vulnerability affects your stack