What’s Vulnerable › Vulnerabilities
CVE-2022-51013: PocketMine-MP before 4.2.3 Denial of Service via NBT Metadata
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-07 · updated 2026-10-08
- Weakness: CWE-20
Description
PocketMine-MP versions before 4.2.3 fail to validate damage metadata values in tool and armor item NBT data received from clients. Attackers can send negative or out-of-range damage values in itemstack NBT to trigger unhandled exceptions in the Durable class, causing server crashes.
Affected products
- pmmp PocketMine-MP: before 4.2.3 — fixed in 4.2.3
How to fix
Upgrade to a fixed version: pmmp PocketMine-MP 4.2.3. Check the vendor advisory for mitigations.
References
- https://github.com/pmmp/PocketMine-MP/commit/c8e1cfcbee4945fd4b63d2a7e96025c59744d4f1
- https://github.com/pmmp/PocketMine-MP/security/advisories/GHSA-46c5-pfj8-fv65
- https://www.vulncheck.com/advisories/pocketmine-mp-before-4.2.3-denial-of-service-via-nbt-metadata
Get alerted when CVE-2022-51013 or the next vulnerability affects your stack