What’s Vulnerable › Vulnerabilities
CVE-2022-51014: PocketMine-MP before 4.0.7 Denial of Service via JSON Decoding
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-07 · updated 2026-10-08
- Weakness: CWE-248
Description
PocketMine-MP before 4.0.7 contains an unhandled exception vulnerability in the ModalFormResponsePacket handler when processing malformed JSON from clients. Attackers can send specially crafted form response packets with invalid JSON to trigger an uncaught InvalidArgumentException, causing server crashes.
Affected products
- pmmp PocketMine-MP: before 4.0.7 — fixed in 4.0.7
How to fix
Upgrade to a fixed version: pmmp PocketMine-MP 4.0.7. Check the vendor advisory for mitigations.
References
- https://github.com/pmmp/PocketMine-MP/commit/56fe71d939c38fe14e18a31a673a9331bcc0e4ca
- https://github.com/pmmp/PocketMine-MP/security/advisories/GHSA-wjfq-88q2-r34j
- https://www.vulncheck.com/advisories/pocketmine-mp-before-4.0.7-denial-of-service-via-json-decoding
Get alerted when CVE-2022-51014 or the next vulnerability affects your stack