What’s Vulnerable › Vulnerabilities
CVE-2022-51015: PocketMine-MP before 4.0.6 Denial of Service via PlayerActionPacket
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-07 · updated 2026-10-08
- Weakness: CWE-20
Description
PocketMine-MP before 4.0.6 does not validate facing values in PlayerActionPacket (for START_BREAK and CRACK_BREAK actions) or in UseItemTransactionData (typically within InventoryTransactionPacket). A remote authenticated attacker can send crafted packets with invalid facing values (e.g., negative or out-of-range) to crash the server, resulting in a denial of service.
Affected products
- pmmp PocketMine-MP: before 4.0.6 — fixed in 4.0.6
How to fix
Upgrade to a fixed version: pmmp PocketMine-MP 4.0.6. Check the vendor advisory for mitigations.
References
- https://github.com/pmmp/PocketMine-MP/commit/f126479c37ff00a717a828f5271cf8e821d12d6c
- https://github.com/pmmp/PocketMine-MP/security/advisories/GHSA-xh99-hw7h-wf63
- https://www.vulncheck.com/advisories/pocketmine-mp-before-4.0.6-denial-of-service-via-playeractionpacket
Get alerted when CVE-2022-51015 or the next vulnerability affects your stack