What’s Vulnerable › Vulnerabilities
CVE-2022-51017: PocketMine-MP before 3.26.5 and 4.0.5 Denial of Service via Skin Data
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-07 · updated 2026-10-08
- Weakness: CWE-20
Description
PocketMine-MP versions before 3.26.5 and 4.0.5 fail to validate the length of skin data fields submitted by players, allowing uncapped values to exceed the 32767 byte TAG_String limit. Attackers can submit oversized skin data fields like skinID or geometryName to trigger exceptions during NBT data serialization, causing server crashes.
Affected products
- pmmp PocketMine-MP: from 3.0.0 before 3.26.5; from 4.0.0 before 4.0.5 — fixed in 3.26.5, 4.0.5
How to fix
Upgrade to a fixed version: pmmp PocketMine-MP 3.26.5, 4.0.5. Check the vendor advisory for mitigations.
References
- https://github.com/pmmp/PocketMine-MP/commit/6492cac5c10f9fa8443ceddd2191a7b65b73f601
- https://github.com/pmmp/PocketMine-MP/commit/958a9dbf0fe3131ab60319c5a939f5dfbfe5dfbb
- https://github.com/pmmp/PocketMine-MP/security/advisories/GHSA-c6fg-99pr-25m9
- https://www.vulncheck.com/advisories/pocketmine-mp-before-3.26.5-and-4.0.5-denial-of-service-via-skin-data
Get alerted when CVE-2022-51017 or the next vulnerability affects your stack