What’s Vulnerable › Vulnerabilities
CVE-2022-51018: PocketMine-MP before 3.26.5 and 4.0.5 Input Validation via Book Pages
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-07 · updated 2026-10-08
- Weakness: CWE-400
Description
PocketMine-MP before 3.26.5 and 4.0.x before 4.0.5 does not limit book page text length, page count, or author/title length. A player who obtains a writable book can create oversized NBT ('book bombs'), causing excess bandwidth consumption and server crashes (exceeding the 1 MB chunk size limit when saving region-based worlds in PM3, or exceeding the 32 KiB TAG_String limit in PM4).
Affected products
- pmmp PocketMine-MP: from 3.0.0 before 3.26.5; from 4.0.0 before 4.0.5 — fixed in 3.26.5, 4.0.5
How to fix
Upgrade to a fixed version: pmmp PocketMine-MP 3.26.5, 4.0.5. Check the vendor advisory for mitigations.
References
- https://github.com/pmmp/PocketMine-MP/security/advisories/GHSA-p62j-hrxm-xcxf
- https://www.vulncheck.com/advisories/pocketmine-mp-before-3.26.5-input-validation-via-book-pages
Get alerted when CVE-2022-51018 or the next vulnerability affects your stack