What’s Vulnerable › Vulnerabilities
CVE-2023-0005: PAN-OS: Exposure of Sensitive Information Vulnerability
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-12 · updated 2026-06-17
- Weakness: CWE-497
Description
A vulnerability in Palo Alto Networks PAN-OS software enables an authenticated administrator to expose the plaintext values of secrets stored in the device configuration and encrypted API keys.
Affected products
- Palo Alto Networks PAN-OS: from 8.1.0 before 8.1.24; from 9.0.0 before 9.0.17; from 9.1.0 before 9.1.15; from 10.0.0 before 10.0.12; from 10.1.0 before 10.1.8; from 10.2.0 before 10.2.3 — fixed in 8.1.24, 9.0.17, 9.1.15, 10.0.12, 10.1.8, 10.2.3
- Palo Alto Networks PAN-OS: from 10.2 before 10.2.3; from 10.1 before 10.1.8; from 10.0 before 10.0.12; from 9.1 before 9.1.15; from 9.0 before 9.0.17; from 8.1 before 8.1.24 — fixed in 10.2.3, 10.1.8, 10.0.12, 9.1.15, 9.0.17, 8.1.24
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 8.1.24, 9.0.17, 9.1.15, 10.0.12; Palo Alto Networks PAN-OS 10.2.3, 10.1.8, 10.0.12, 9.1.15. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2023-0005
- https://security.paloaltonetworks.com/CVE-2023-0005
Get alerted when CVE-2023-0005 or the next vulnerability affects your stack