What’s Vulnerable › Vulnerabilities
CVE-2023-0007: PAN-OS: Stored Cross-Site Scripting (XSS) Vulnerability in the Panorama Web Interface
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-10 · updated 2026-06-17
- Weakness: CWE-80
Description
A cross-site scripting (XSS) vulnerability in Palo Alto Networks PAN-OS software on Panorama appliances enables an authenticated read-write administrator to store a JavaScript payload in the web interface that will execute in the context of another administrator’s browser when viewed.
Affected products
- Palo Alto Networks PAN-OS: from 8.1.0 before 8.1.25; from 9.0.0 before 9.0.17; from 9.1.0 before 9.1.16; from 10.0.0 before 10.0.7 — fixed in 8.1.25, 9.0.17, 9.1.16, 10.0.7
- Palo Alto Networks PAN-OS: from 10.0 before 10.0.7; from 9.1 before 9.1.16; from 9.0 before 9.0.17; from 8.1 before 8.1.25 — fixed in 10.0.7, 9.1.16, 9.0.17, 8.1.25
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 8.1.25, 9.0.17, 9.1.16, 10.0.7; Palo Alto Networks PAN-OS 10.0.7, 9.1.16, 9.0.17, 8.1.25. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2023-0007
- https://security.paloaltonetworks.com/CVE-2023-0007
Get alerted when CVE-2023-0007 or the next vulnerability affects your stack