What’s Vulnerable › Vulnerabilities
CVE-2023-0030
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-08 · updated 2026-06-17
- Weakness: CWE-416
Description
A use-after-free flaw was found in the Linux kernel’s nouveau driver in how a user triggers a memory overflow that causes the nvkm_vma_tail function to fail. This flaw allows a local user to crash or potentially escalate their privileges on the system.
Affected products
- Linux kernel: before 5.0 — fixed in 5.0
How to fix
Upgrade to a fixed version: Linux kernel 5.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2157270
- https://github.com/torvalds/linux/commit/729eba3355674f2d9524629b73683ba1d1cd3f10
- https://security.netapp.com/advisory/ntap-20230413-0010/
- https://bugzilla.redhat.com/show_bug.cgi?id=2157270
- https://github.com/torvalds/linux/commit/729eba3355674f2d9524629b73683ba1d1cd3f10
- https://security.netapp.com/advisory/ntap-20230413-0010/
- https://bugzilla.redhat.com/show_bug.cgi?id=2157270
Get alerted when CVE-2023-0030 or the next vulnerability affects your stack