What’s Vulnerable › Vulnerabilities
CVE-2023-0033: PDF Viewer < 1.0.0 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-30 · updated 2026-06-17
Description
The PDF Viewer WordPress plugin before 1.0.0 does not validate and escape one of its shortcode attributes, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attack.
Affected products
- PDF Viewer: before 1.0.0 — fixed in 1.0.0
How to fix
Upgrade to a fixed version: PDF Viewer 1.0.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/2d9ae43b-75a7-4fcc-bce3-d9e9d7a97ec0
- https://wpscan.com/vulnerability/2d9ae43b-75a7-4fcc-bce3-d9e9d7a97ec0
Get alerted when CVE-2023-0033 or the next vulnerability affects your stack