What’s Vulnerable › Vulnerabilities
CVE-2023-0051: Heap-based Buffer Overflow in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-04 · updated 2026-06-17
- Weakness: CWE-122
Description
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.1144.
Affected products
- vim/vim: before 9.0.1144 — fixed in 9.0.1144
How to fix
Upgrade to a fixed version: vim/vim 9.0.1144. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2023/Mar/17
- https://github.com/vim/vim/commit/c32949b0779106ed5710ae3bffc5053e49083ab4
- https://huntr.dev/bounties/1c8686db-baa6-42dc-ba45-aed322802de9
- https://security.gentoo.org/glsa/202305-16
- https://support.apple.com/kb/HT213670
- http://seclists.org/fulldisclosure/2023/Mar/17
- https://github.com/vim/vim/commit/c32949b0779106ed5710ae3bffc5053e49083ab4
- https://huntr.dev/bounties/1c8686db-baa6-42dc-ba45-aed322802de9
- https://security.gentoo.org/glsa/202305-16
- https://support.apple.com/kb/HT213670
Get alerted when CVE-2023-0051 or the next vulnerability affects your stack