What’s Vulnerable › Vulnerabilities
CVE-2023-0054: Out-of-bounds Write in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-04 · updated 2026-06-17
- Weakness: CWE-787
Description
Out-of-bounds Write in GitHub repository vim/vim prior to 9.0.1145.
Affected products
- vim/vim: before 9.0.1145 — fixed in 9.0.1145
How to fix
Upgrade to a fixed version: vim/vim 9.0.1145. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2023/Mar/17
- https://github.com/vim/vim/commit/3ac1d97a1d9353490493d30088256360435f7731
- https://huntr.dev/bounties/b289ee0f-fd16-4147-bd01-c6289c45e49d
- https://lists.debian.org/debian-lts-announce/2023/06/msg00015.html
- https://security.gentoo.org/glsa/202305-16
- https://support.apple.com/kb/HT213670
- http://seclists.org/fulldisclosure/2023/Mar/17
- https://github.com/vim/vim/commit/3ac1d97a1d9353490493d30088256360435f7731
- https://huntr.dev/bounties/b289ee0f-fd16-4147-bd01-c6289c45e49d
- https://lists.debian.org/debian-lts-announce/2023/06/msg00015.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00023.html
- https://security.gentoo.org/glsa/202305-16
Get alerted when CVE-2023-0054 or the next vulnerability affects your stack