What’s Vulnerable › Vulnerabilities
CVE-2023-0060: Responsive Gallery Grid < 2.3.9 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-13 · updated 2026-06-17
Description
The Responsive Gallery Grid WordPress plugin before 2.3.9 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- Responsive Gallery Grid Project Responsive Gallery Grid: before 2.3.9 — fixed in 2.3.9
How to fix
Upgrade to a fixed version: Responsive Gallery Grid Project Responsive Gallery Grid 2.3.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/be2fc859-3158-4f06-861d-382381a7551b
- https://wpscan.com/vulnerability/be2fc859-3158-4f06-861d-382381a7551b
Get alerted when CVE-2023-0060 or the next vulnerability affects your stack