What’s Vulnerable › Vulnerabilities
CVE-2023-0062: EAN for WooCommerce < 4.4.3 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-06 · updated 2026-10-28
Description
The EAN for WooCommerce WordPress plugin before 4.4.3 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- WPFactory EAN for WooCommerce: before 4.4.3 — fixed in 4.4.3
How to fix
Upgrade to a fixed version: WPFactory EAN for WooCommerce 4.4.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/450f94a3-56b1-41c7-ac29-fbda1dc04794
- https://wpscan.com/vulnerability/450f94a3-56b1-41c7-ac29-fbda1dc04794
Get alerted when CVE-2023-0062 or the next vulnerability affects your stack