What’s Vulnerable › Vulnerabilities
CVE-2023-0072: WC Vendors Marketplace < 2.4.5 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-06 · updated 2026-06-17
Description
The WC Vendors Marketplace WordPress plugin before 2.4.5 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- WCVendors WC Vendors Marketplace: before 2.4.5 — fixed in 2.4.5
How to fix
Upgrade to a fixed version: WCVendors WC Vendors Marketplace 2.4.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/bb2b876f-7216-4f31-9d1f-a45405c545ce
- https://wpscan.com/vulnerability/bb2b876f-7216-4f31-9d1f-a45405c545ce
Get alerted when CVE-2023-0072 or the next vulnerability affects your stack