What’s Vulnerable › Vulnerabilities
CVE-2023-0074: WP Social Widget < 2.2.4 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-30 · updated 2026-06-17
Description
The WP Social Widget WordPress plugin before 2.2.4 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- catchsquare WP Social Widget: before 2.2.4 — fixed in 2.2.4
How to fix
Upgrade to a fixed version: catchsquare WP Social Widget 2.2.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/82f543e3-9397-4364-9546-af5ea134fcd4
- https://wpscan.com/vulnerability/82f543e3-9397-4364-9546-af5ea134fcd4
Get alerted when CVE-2023-0074 or the next vulnerability affects your stack