What’s Vulnerable › Vulnerabilities
CVE-2023-0079: Customer Reviews for WooCommerce < 5.17.0 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-16 · updated 2026-06-17
- Weakness: CWE-79
Description
The Customer Reviews for WooCommerce WordPress plugin before 5.17.0 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- ivole Customer Reviews for WooCommerce: before 5.17.0 — fixed in 5.17.0
How to fix
Upgrade to a fixed version: ivole Customer Reviews for WooCommerce 5.17.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/fdaba4d1-950d-4512-95de-cd43fe9e73e5/
- https://wpscan.com/vulnerability/fdaba4d1-950d-4512-95de-cd43fe9e73e5/
Get alerted when CVE-2023-0079 or the next vulnerability affects your stack