What’s Vulnerable › Vulnerabilities
CVE-2023-0089: Proofpoint Enterprise Protection webutils authenticated RCE
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-08 · updated 2026-06-17
- Weakness: CWE-95
Description
The webutils in Proofpoint Enterprise Protection (PPS/POD) contain a vulnerability that allows an authenticated user to execute remote code through 'eval injection'. This affects all versions 8.20.0 and below.
Affected products
- Proofpoint Enterprise Protection: before 8.13.22; from 8.18.0 before 8.18.4; 8.18.6, 8.20.0 — fixed in 8.13.22, 8.18.4
How to fix
Upgrade to a fixed version: Proofpoint Enterprise Protection 8.13.22, 8.18.4. Check the vendor advisory for mitigations.
References
- https://www.proofpoint.com/security/security-advisories/pfpt-sa-2023-0001
- https://www.proofpoint.com/security/security-advisories/pfpt-sa-2023-0001
Get alerted when CVE-2023-0089 or the next vulnerability affects your stack