What’s Vulnerable › Vulnerabilities
CVE-2023-0096: Happyforms < 1.22.0 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-06 · updated 2026-06-17
Description
The Happyforms WordPress plugin before 1.22.0 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- Happyforms: before 1.22.0 — fixed in 1.22.0
How to fix
Upgrade to a fixed version: Happyforms 1.22.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/b28150e7-214b-4bcd-85c0-e819c4223484
- https://wpscan.com/vulnerability/b28150e7-214b-4bcd-85c0-e819c4223484
Get alerted when CVE-2023-0096 or the next vulnerability affects your stack