What’s Vulnerable › Vulnerabilities
CVE-2023-0097: Post Grid, Post Carousel, & List Category Posts < 2.4.19 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-30 · updated 2026-06-17
- Weakness: CWE-79
Description
The Post Grid, Post Carousel, & List Category Posts WordPress plugin before 2.4.19 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- Smart Post Show: before 2.4.19 — fixed in 2.4.19
How to fix
Upgrade to a fixed version: Smart Post Show 2.4.19. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/19379f08-d667-4b1e-a774-0f4a17ad7bff
- https://wpscan.com/vulnerability/19379f08-d667-4b1e-a774-0f4a17ad7bff
Get alerted when CVE-2023-0097 or the next vulnerability affects your stack