What’s Vulnerable › Vulnerabilities
CVE-2023-0107: Cross-site Scripting (XSS) - Stored in usememos/memos
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-07 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository usememos/memos prior to 0.10.0.
Affected products
- usememos/memos: before 0.10.0 — fixed in 0.10.0
How to fix
Upgrade to a fixed version: usememos/memos 0.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/usememos/memos/commit/0f8ce3dd1696722f951d7195ad1f88b39a5d15d7
- https://huntr.dev/bounties/0b28fa57-acb0-47c8-ac48-962ff3898156
- https://github.com/usememos/memos/commit/0f8ce3dd1696722f951d7195ad1f88b39a5d15d7
- https://huntr.dev/bounties/0b28fa57-acb0-47c8-ac48-962ff3898156
Get alerted when CVE-2023-0107 or the next vulnerability affects your stack